Python OS X 10.5 yılında dizin planına uyması için yükleyin

oy
2

Varsayılan Python X 10.5 FAT 32 bit (Intel ve PPC) müşteri ile 2.5.1 olan OS üzerinde yükleyin. Ben Django çalıştırmak için Apachenin ve mysql istiyorum. Geçmişte, bu 32 bit modda yüklemek maç için Apache ve MySQL çalıştırdığınız (hatta o iş yapmak Apache'den 64 bit şeyler dışarı çıkarılarak).

Ben 64 bit'e Python yükseltmek istiyorum. Ben bir uyarı ile kaynağından derleyerek tamamen rahatım. Nasıl düzenlendiği varsayılan yüklemek böyle maç mı? Özellikle site paketlere Saygılarımızla olmak ile /Library/Python/2.5/değil, bunu derlemek kez çerçevenin üst kısmında gömülü bir.

Oluştur 27/08/2008 saat 09:22
kaynak kullanıcı
Diğer dillerde...                            


5 cevaplar

oy
1

Tamamen sorunuzu anlıyorum ama sadece böylece /Library/Python/2.5 ve noktasının altındaki pitonun senin taze inşa sürüme sembolik bağlantılar kurmak ve 64 bit sürümünü yükleyip sonra yaratamaz emin değil misiniz?

Cevap 27/08/2008 saat 15:30
kaynak kullanıcı

oy
0

Esasen, evet. Sana (güncel sürümü bunu böyle yapmaz) bunu böyle yapabilirdi emin değildi. piton yüklemek script kullanarak, ancak, (örneğin prefix) dizinleri ve dosyaları nereye koyacağını belirtmek için bir seçeneğin (ı bulabilmesi) bulunmaktadır. Ben gereksiz dosyaları ile benim makine 'kirletici' önlemek için piton ilgili dosyaların güncel planına uyması için umuyordum.

Cevap 27/08/2008 saat 22:38
kaynak kullanıcı

oy
1

Eğer bir sorununuz görene kadar Şahsen ben bu konuda endişe olmaz. Varsayılan piton Messing bu değer daha fazla sorun neden olabilir bir * Nix sistemine yükleyin. Ben gerçekten onunla bir sorun var kadar nix dünya için ne yaptığını piton anlamaya asla kişisel deneyimlerinden söyleyebiliriz.

Ayrıca ikinci bir piton yükleme ekleyebilirsiniz, ancak IMO değerinden daha o zamanda daha sorunlara neden olmaktadır.

Bu yüzden iyi soru tam olarak pitonun 64 bit sürümünü kullanmak istiyorsunuz neden olacaktır ile işe başlamak için herhalde?

Cevap 27/08/2008 saat 23:09
kaynak kullanıcı

oy
0

Kısa cevap çünkü yapabilirim olduğunu. Uzun cevabı, OP söylediklerimi genişleyen, apache ve mysql / postgresql ile daha uyumlu olmaktır. Onlar (apache diğerleri sadece düz 64bit, ppc, ppc64 x86 ve x86 ve x86_64 ile şişman ikili olan) tüm 64bit vardır. Mysqldb ve Mod_python alışkanlık hepsi aynı mimariyi çalıştıran sürece derlemek. Evet ben 32bit hepsini çalıştırın (ve geçmişte var) ama bu kadar sonra bir program derleme daha fazla çalışma olabilir.

DÜZENLEME: Sadece yükleyici, şey yapalım ve bunu yansıtacak şekilde PATH güncellemek için olsa Hemen hemen ikna etti.

Cevap 27/08/2008 saat 23:33
kaynak kullanıcı

oy
1

Hyposaurus,

Python aynı anda yüklü birden çok sürümü mümkündür. paralel olarak iki sürümü yüklenmesi sorunu çözer ve yukarıda Jason Baker tarafından düzenlendiği sorunlardan kaçınmak yardımcı olur.

En kolay yolu, ve ben tavsiye yolu kullanmaktır MacPorts ayrı tüm yazılım yüklemek olacaktır. Varsayılan olarak, örneğin, her şey / opt / yerel yüklenir

Başka bir yöntem sadece kaynak indirmek ve belirli bir önek ile derlemek etmektir. Eğer piton yürütülebilir her zaman tam yolunu yazarak kaçınmak istiyorsanız bunu kendin yapmanız gerekir bu nedenle bu yöntem, PATH ortam değişkeni değiştirmek unutmayın

./configure --prefix=/usr/local/python64
make
sudo make install

Sonra sadece Apache Mod_python en kullanarak yeni sürümüne yüklemek işaret edebilir PythonInterpreter direktifini

Cevap 28/08/2008 saat 06:16
kaynak kullanıcı

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more