çalışmıyor İthalat keras.datasets

oy
7

Ben kendi Linux makinede yüklü keras var ama keras.datasets bir veri kümesi içe çalıştığımda onu bulamadığını bir hata alıyorum.

Örneğin Yani:

from keras.datasets import mnist

Hatası alıyorum

ImportError: Hiçbir modül adlı keras.datasets

Ben kullanarak keras yüklü pip installve başarıyla yüklenmiş.

Oluştur 16/02/2016 saat 11:33
kaynak kullanıcı
Diğer dillerde...                            


3 cevaplar

oy
1

Nitekim Sorun Python birden çok sürümünü vardı.

Anaconda Python Çıkarma ve pip kullanan tüm kütüphane yüklemeden / Conda sorunumu çözdü yerine apt-get.

Bunun doğru olduğu ancak anaconda silmek gerekli değildir. Ben ancak birden piton sürümleri ile aynı sorunu vardı. Ancak, ben sadece (o ortamda iken) Anaconda versiyonunu kullanılan bir ortam yarattı. Yazın / kopya (Mac ve uygun olan diğer ucu üzerinde) terminalde

conda create -n dataweekends python=2.7 pandas scikit-learn jupyter matplotlib

dataweekends basitçe oluşturduğunuz ortamın adıdır. Bu erişmek için, sadece komutunu kullanın

source activate dataweekends

Eğer (muhtemelen) yeni ortamda bir kez bağımlılıkları yeniden kurmanız gerekebilir dikkatli olun.

Ben buradan bu hileyi "var https://www.dataweekends.com/blog/2017/03/09/set-up-your-mac-for-deep-learning-with-python-keras-and-tensorflow "

Ben de piton yapmak her proje için farklı ortamlarda kurma öneriyoruz.

Cevap 27/08/2017 saat 16:33
kaynak kullanıcı

oy
1

Eğer var mı keras.pyveya keras.pycgeçerli çalışma dizini? Eğer öyleyse, bu irade pisliği ithalat. Deneyin dosyayı yeniden adlandırmayı ve / veya silmekeras.pyc .

Cevap 05/03/2017 saat 14:24
kaynak kullanıcı

oy
0

doğru yolda beni Selçuk'tan yorumuna teşekkürler.

Nitekim Sorun Python birden çok sürümünü vardı. Python kendi versiyonudur MiniConda / Conda / Anaconda yükleme önerilen keras yüklemeden bazı online talimatlarına. Bu yüzden iki Python2.7 versiyonları yüklü vardı:

  • Normal Linux Python 2.7
  • Anaconda Python 2.7

Anaconda Python Çıkarma ve kullanan tüm kütüphaneleri yükleme pip/ apt-getyerine condasorunumu çözdü.

Cevap 16/02/2016 saat 13:42
kaynak kullanıcı

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more