Ben IE11 desteklemek için WebPack içermelidir hangi babel- * paket

oy
0

Ben (örn IE11 desteklemek istiyorsanız NodeList.forEachWebPack içindeki Babel kullanarak Projemdeki), ama kafa karıştırıcı doğru babel paketi seçmek için bulabilirsiniz.

Güncel paketler şunlardır:

@babel/core: ^7.6.4,
@babel/preset-env: ^7.6.3,
babel-loader: ^8.0.6,
webpack: ^4.41.1,
webpack-cli: ^3.3.9

Olası candiates şunlardır:

benim şimdiki webpack.config

             options: {
                compact: false, 
                presets:
                  [[@babel/env, {//env preset
                    targets: {
                      browsers: [last 2 Chrome versions, last 2 Firefox versions, Explorer >= 11]
                    }
                  }]]
              }

Birisi bu paketin her yapar ve IE11 desteklemeye muktedir ne için paket / konfigürasyon ben sırayla içermelidir neyi açıklayabilir NodeList.forEach.

Oluştur 16/10/2019 saat 11:43
kaynak kullanıcı
Diğer dillerde...                            


1 cevaplar

oy
0

Çekirdek-js (yüklü @babel/polyfill) uygulayan NodeList.prototype.forEach()Polyfill olarak. Bkz bu sorunu .

İçe Yani eğer core-js/stableönerildiği üzere Babil belgelerinde , NodeList.prototype.forEach()zaten yoksa uygulanacaktır.

import "core-js/stable";
Cevap 16/10/2019 saat 12:02
kaynak kullanıcı

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more